Excel : démystifions la fonction SI

Que celui qui ne s'est jamais bagarré avec la fonction SI lève la main ! ( Attention ! Je ne parle pas des cas simples, attendez d'avoir lu jusqu'à la fin avant de garder la main baissée... )

Pour ceux qui utilisent excel sans les fonctions (beaucoup plus qu'on ne le pense), je définis la fonction SI. (Peut être définir ce qu'est une fonction avant ?)

Une fonction (dans Excel) : c'est un raccourci qui effectue un traitement sur une information donnée. Un exemple. Pour calculer une moyenne, il faut :

  • compter toutes les valeurs,
  • en faire la somme,
  • puis diviser la somme par le nombre de valeurs. 3 opérations ! Une fonction dans excel, fait cela en une passe :-).

Donc la fonction SI, va permettre de tester une valeur et d'effectuer une action en fonction du résultat du test. Cette fonction est très puissante une fois que sa mécanique est comprise. Quand je parle de mécanique, je parle de la réflexion logique qui l'accompagne. Donc pour comprendre cette mécanique, je vais vous proposer un problème simple :

Nous souhaitons gérer la prime des commerciaux qui ont un objectif de 1500 unités par mois. Ils reçoivent une prime (0,15 € par unité vendue) si l'objectif est atteint ou dépassé. Rien dans le cas contraire.

Détournons un outil "d'informaticien" (le logigramme), pour mieux apréhender la mécanique (logique) : logigramme

Quelques explications :

  • Pour faire simple, les losanges représentent un test (une comparaison, plus grand que, plus petit que, existe ou n'existe pas, ....). Les rectangles une entrée de données (ou une affectation de résultat)
  • Dans un losange, la sortie basse est toujours le résultat si le test échoue, la sortie droite le résultat si le test réussit.

Une fois cela posé, cela semble plutôt simple sur ce cas. Le schéma parle de lui même:

cellules

Je saisie en A1 les unités vendues et j'espère obtenir en A2 le montant de la prime en saisissant la formule :

= SI(A1>=1500 ; 0,15*A1; 0)

Simple, très simple. Faisons plus compliqué en changeant les données du problèmes :

  • La prime est de 0,10 € (prime niv 2) si le nombre d'unités vendues dépasse 1250 (objectif 2).
  • Elle est de 0,15€ (prime niv 1) si le nombre d'unités vendues dépasse 1500 (objectif 1).

Donc ici nous avons 2 conditions à vérifier. Le logigramme resemblerait à ceci : logigramme2

Notez bien que l'on commence toujours par tester la plus grande condition. Cela élimine les conditions par le bas (moins de vérifications à faire).

Sans trop d'effort, vous venez d'imbriquer une fonction SI dans une autre fonction SI. En dessinant le logigramme, vous êtes en mesure d'intégrer un nombre impressionnant de conditions sans vous tromper dans la logique :-).

Permettez moi de vous suggérer d'abuser (sans aucune modération) de cet outil avant d'attaquer vos formules. Une feuille et un crayon, vos meilleurs alliés pour être imbattable en fonction SI.

Avez-vous envie de levez la main pour répondre à la question du début maintenant ?

J'espère vous avoir été utile. A bientôt pour un nouvel article.

Thierry BOULOGNE
Développeur / Formateur bureautique

Next Post Previous Post

comments powered by HyperComments